Results 1 to 9 of 9

Thread: no options to 'Lock IE ...' in IE tweaks

Hybrid View

  1. #1
    Junior Member
    Join Date
    Jan 2012
    Posts
    4

    Default no options to 'Lock IE ...' in IE tweaks

    Hi all,

    When I go to the proxy settings in MSIE or in Chrome, I get this message: "access to this feature has been disabled by a restriction set by your system administrator"

    After Googling a bit, it turns out this is most commonly due to either two registry keys being set, or due to Spybot settings. I checked and I don't have the registry keys, so I turned to Spybot.

    The Spybot documentation at http://www.safer-networking.org/en/faq/24.html mentions this:
    Select Tools in the left bar, then IE tweaks.
    There you will see a group Recommended miscellaneous locks. Untick the checkboxes in front of both Lock IE... options.
    However, I don't have those options. I'm using version 1.6.2.46, and in IE tweaks, I only see the "lock hosts file" and the custom title options. The attached screenshot illustrates it.

    Am I doing something wrong? Or has this changed recently in Spybot, and has the documentation not been updated yet?

    Thanks a lot,
    Ludovic
    Attached Images Attached Images

  2. #2
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    3,818

    Default

    Are you using Windows 7 or Vista?
    If so,please see here:
    http://forums.spybot.info/showthread.php?t=51180
    Spybot locks access to Internet Options via the registry,and if my memory serves correctly,there is an option to set the restriction to the current user,or on all accounts,depending on which option you checkmark.
    So if it had been set due to Spybot,the self-same registry keys you were looking for would have been present at either HKLM or HKCU.

    That is what happens on Internet Explorer?When you click Tools,then Internet Options,you get the "access to this feature has been disabled by a restriction set by your system administrator" message?

  3. #3
    Junior Member
    Join Date
    Jan 2012
    Posts
    4

    Default

    Hi Zenobia,

    Thanks a lot for the info! Yes, I'm using Windows 7 indeed. That explains why the IE tweaks option is gone.

    I just checked again, the registry keys aren't there: there's just no "Internet Explorer" folder within the software->policies directory; and searching the entire registry for "NoBrowserOptions" didn't find anything.

    Very strange issue... But I guess it's not related to Spybot, so I guess I'll have to take my problem to a more general Windows discussion forum :-). Thanks again for your help.

  4. #4
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    3,818

    Default

    You're welcome.
    Did you see a Microsoft folder in the registry?
    The path is normally HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions
    or HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
    Restrictions

    Also,do you get the "access to this feature has been disabled by a restriction set by your system administrator" message when attempting to select Internet Options?
    It is possible to set a registry key to disable changes to Proxy settings.Though,I'm not 100% sure on this,but I believe that just causes the proxy settings to appear dimmed.

  5. #5
    Junior Member
    Join Date
    Jan 2012
    Posts
    4

    Default

    I do have a "Microsoft" folder in HKEY_CURRENT_USER\Software\Policies\Microsoft, just no "Internet Explorer" within it.

    However, there's a "HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\" -- but no "Restrictions" in it (see attached -- basically all its subdirs are empty, except for some Canon stuff).


    You're right, I wasn't very clear about the error message. If in MSIE I go to the menu Tools -> Internet Options, I can see all the tabs, except for the "Connections" tab which is missing.

    The error message is what appears if I either (1) go to the Control Panel, search for "Proxy" and click on "Configure Proxy Server" or (2) open Chrome, go to options -> advanced and click on the proxy config button.
    Attached Images Attached Images

  6. #6
    Junior Member
    Join Date
    Jan 2012
    Posts
    4

    Default

    Just checked again, and noticed it's fixed now. Not sure what I've done.

    Yesterday I did run gpedit.msc, went to Administrative Templates under the User Configuration node -> Windows Components -> Internet Explorer -> Internet Control Panel, then double-clicked on "disable the connections page". It said "not configured", I click on "disabled".

    However, when I go back there, I notice it still says "not configured". Very strange.

    Thanks a lot for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •