Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: !!!Bad checksum!?

  1. #1
    Junior Member
    Join Date
    Oct 2005
    Posts
    2

    Question !!!Bad checksum!?

    I've been trying to download the updates from 2005-10-21, and every time I attempt to do so, I get the message !!!bad checksum! and can't get the updates. I was running an older version of SpybotS&D, and I still have the problem with the newest version.

  2. #2
    Spybot Advisor Team [Retired] md usa spybot fan's Avatar
    Join Date
    Oct 2005
    Posts
    5,879

    Default

    "Bad Checksum" problems can be overcome in most cases by changing the download server (site) as follows:
    1. Do not click "Search for Updates" again.
    2. Using the pull-down site selection menu (between the "Search for Updates" and "Download Updates" buttons) select another server.
    3. After changing the download server click "Download Updates" again.
    4. If you get another "Bad Checksum", repeated Steps 2 & 3 (using a 3rd or 4th server if necessary) until all updates are received.
    Attached Images Attached Images

    Getting an answer is one thing, learning is another.


    Microsoft Windows XP Home Edition running on a 2.40GHz Intel® Pentium® 4 Processor with 512 MB of RAM and a 533 MHz System Bus.

  3. #3
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    560

    Default

    scubasteve: Could you please post the name of the download server that is giving you the "Bad Checksum" message?

    We've been trying to discover and fix issues with these servers and would be very interested which servers are still giving these errors and which are working well, so please tell us both. Also, please mention your location; State (US) or Country is good enough.

    Follow the instructions by md usa spybot fan in the post above to pick the server(s) and find their names.

    Thanks,
    bitman

  4. #4
    Junior Member
    Join Date
    Oct 2005
    Posts
    2

    Smile

    Thanks, that really helped. The server that was giving me problems was the See-Cure#1, and the one that worked for me was See-Cure#2. I'm in California.

  5. #5
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    560

    Default

    Thanks Steve, those are both in Germany, but we have seen continued issues with See-Cure #1.

    I suggest that you give the new BN FileForum (World) server a try for the next set of updates. This is actually several servers all over the world, with one right there in California.

    Let us know how it works if you get the chance, your input has already been helpful to everyone using Spybot.

    Bitman

  6. #6
    Translator Team Said Bakr's Avatar
    Join Date
    Oct 2005
    Location
    Kafr Sakr, Egypt
    Posts
    26

    Default

    Yes it is a great solution for CheckSum problem. I have a suggestion to SpyBot developers. The button of updates downloading server should be named by this name.
    for ($i = 0; $i != -1; $i++){
    echo "Best Regards";
    }

  7. #7
    Junior Member
    Join Date
    Oct 2005
    Posts
    2

    Default checksum error

    This is all well and gooed, except on my "pull down" menu there is NO option to select a download server (I have been reccommending your product to my customers for months now, and I am getting inundated by calls from customers who are getting the same error when attempting an update)...

  8. #8
    Junior Member
    Join Date
    Oct 2005
    Posts
    2

    Default check sum error

    Ok; please ignore my last post; we eventually managed to get a pull down menu. However, having passed this information along to my clients (all based here in the USA) checksum errors are still being obtained from the following mirror sites:

    BNFileforum
    SecurityWorks.net and SecurityWorks.org
    SaferNetworking

    I have also been able to duplicate the same errors reported to me by my customers with those mirrors.

  9. #9
    Junior Member
    Join Date
    Nov 2005
    Posts
    17

    Default modify [-Mirrors] section of 'online.ini'

    How about some insight on how to modify the [-Mirrors] section of 'online.ini' (in: C:\Program Files\Spybot - Search & Destroy\Updates) so that the problematic mirror (See-Cure #1 (Europe)=http://www.see-cure.de/updates/files/) can be selectively eliminated from the download mirrors drop-down list.
    FYI - I am in western Canada.
    Because this problem mirror is 1st on the list, the Spybot S&D program grinds away (and away) on launch (I have my Settings>Settings>Web update>(1st three options) enabled) trying to pull down a good set of update files (when they are available). I invariably have to Search for Updates manually and select a different mirror to get good checksum update files.
    I would experiment with modification of 'online.ini' myself but I see that Mirrors are referenced repeatedly in this file, all preceded by a checksum routine, therefore, I am guessing that anything I do to the file will wind up generating errors if not done correctly.
    Another thing that bugs me is the fact that when a new version of Spybot S&D is released (ie. v1.4), no advice of same is ever generated by the program (v1.3), even though it dutifully continues to pull down the latest update files. One must find out by other means - not very efficient.
    In every corporate organization, there will be an individual who knows everything that goes on at any given moment - this person MUST be fired immediately!

  10. #10
    Spybot Advisor Team [Retired] md usa spybot fan's Avatar
    Join Date
    Oct 2005
    Posts
    5,879

    Default

    There is no way to:

    Quote Originally Posted by Frankenstien
    … modify the [-Mirrors] section of 'online.ini' (in: C:\Program Files\Spybot - Search & Destroy\Updates) so that the problematic mirror (See-Cure #1 (Europe)=http://www.see-cure.de/updates/files/) can be selectively eliminated from the download mirrors drop-down list.
    Since that file is refreshed from the download of the www.safer-networking.org/updates/spybotsd.ini (in Spybot 1.4) before the required updates are listed.

    Please try the following:
    • After you do a "Search for updates", select an alternate server then right click on that server and "Set this server as the preferred download location".

    See if that elevates you problem.

    Getting an answer is one thing, learning is another.


    Microsoft Windows XP Home Edition running on a 2.40GHz Intel® Pentium® 4 Processor with 512 MB of RAM and a 533 MHz System Bus.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •