View Full Version : Host file is inactive

2005-10-30, 22:24
Using XP home and running SB 1.3 (past) and now 1.4.
I need to set some host for the local network and use the host-tabel for this.
I can see this files to be updated with bad products or sites, I also inserted a few hosts in this tabel.
However: The os seems to ignore this tabel. I tested this with ping.
ping <tabel-entry> schould give local-host for the bad products or my ref, for my manual entries.
How to solve this? Any help is welcome

2005-10-30, 22:39
Do you connect to your Internet Service Provider via a proxy....similar to America Online or are you a remote proxy user ?

Do you use proxy type programs like Proxomitron ?

2005-10-31, 21:59
Do you connect to your Internet Service Provider via a proxy....similar to America Online or are you a remote proxy user ?

Do you use proxy type programs like Proxomitron ?
No i do not use any proxy. It worked last year perfect, in the last 6 month I lost this ability al. As I used the ip-number by then, I did not realy care about this. But now (due to other host-requirements) I do need this host-table.

The more cuncurning thing: The forwarding of bad-hosts to localhost is not working either as the redirection is not effective.

2005-11-01, 19:39
Maybe there is an error in the format/layout of the file:

1. Any comment lines must start with #

2. The first non comment line must be localhost

(note: is the default IP for local host; in principle you could have a different IP defining local host)

3. thereafter non comment entries should be in the form

IP space domain

(note: usually the IP would be, i.e. local host, but it is possible to redirect a domain to any IP)

Another possibility is that if the file was saved in Notepad, the .txt extension was added, as Notepad tends to do that. HOSTS has no filetype extension. To make sure that it has no extension, in Folder options, view tab, uncheck hide extensions for known file types.

2005-11-04, 21:56
Part of the hosts-table, it follows the rules for this table localhost www.site1.nl linuxhost www.site2.com www.site3.com www.site4.nl sander
# Start of entries inserted by Spybot - Search & Destroy babe.the-killer.bz babe.k-lined.com

If I do: ping babe.k-lined.com it trys to reach host A ping to babe.the-killer.bz tries to ping This means IMHO that the function of the host-table is inactive. Is this a security-issue?

2005-11-13, 20:37
I cannot find the error. The hosts-file is setup as required and is being updated/maintained by SB. The system is not using this file and therefore the system is NOT SECURE.

There must be some adjustment in the system making this possible. My fear is that this is due to a virus/malware. Can anyone help please.

2005-11-14, 02:35

has a section on priorities in resolving domain names; I don't know if it is relevant, but might be a straw to clutch at :-)

2005-11-14, 19:38
Looked at

Great site, but ...... they (nor one of the links) could give me the answer.

I tried to play with the "HostsPriority" as advised. Did not help... as well.

Any idea's?

2006-01-04, 12:52
I can only guess, but it could be an issue with winsock
please post a Spybot report, which includes the Winsocklist.

does this issue only appear on your computer and profile?
normally Windows should use the hosts file first and then query DNS-servers