View Full Version : Immunization Problems

Always Confused
2007-07-26, 18:13
Using Spybot (and at least one earlier beta-test release), I have been encountering repeated immunization problems.

For example: Yesterday, I updated Spybot, and started the immunization process. After a while, the process stopped, and I could not close Spybot from within Spybot.

I used the Windows (XP Home, SP2) Task Manager to close the process, and restarted Spybot; the same problem arose, so I repeated the steps to close and restart.

After perhaps two or three attempts to immunize, Spybot did increased the number of immunized entries before it once again gave up. It took me some five or more tries to finally get everything done.

There were quite a few unimmunized entries, as I had recently removed and reinstalled Firefox, but the places where Spybot stopped, according to the immunization screen, were before it got to the Firefox entries. In fact, the part of immunizing the Firefox entries went rather quickly--again, according to what I could see on the Spybot screen, as I have no way of knowing what Spybot was actually doing.

This is not the first time that I've had problems with the immunization process of the Spybot beta-tests; the previous times were much the same as yesterday, although not so serious in terms of how many times I had to kill Spybot and restart the immunization process.

2007-07-26, 19:12
go to TOOLS --> HOST FILES --> then hit the ADD Spybot host file list button at the top. Then reimmunize, restart client and test to see if it works then

Always Confused
2007-07-27, 00:27
1. I hit the "add Spybot host file list".

2, Started Immunization, which showed some items not immunized, so I ran Immunization. Result: 72 Firefox items left not immunized, with immunization process apparently complete, judging by progress bar and the "building" icon at upper-left having stopped.

(24 items each in Firefox images/installations/popups marked as not immunized.)

Out of curiosity, I again ran immunization without doing anything else, meaning that, apparently, immunization had completed without hanging Spybot, but without finishing the immunization process. The process began, then the program hung.

3. Used Task Manager to close Spybot.

4. Restarted immunization, which immediately stated that all files were immunized; the 72 Firefox items were marked as immunized. Progress bar went to right end, process stopped, program active (that is, I could change to another module without needing to use Task Manager.)

2007-07-27, 01:04
what operating system you got? What version of FF?

Always Confused
2007-07-27, 03:05
Windows XP Home, SP2


2007-07-27, 04:08
Theres problems with immunization, i found a few, the program seems to need restarting after updates are downloaded before attempting to immunize, anyway will test next candidate for bugs.
I reported a few but yeah they dont sticky them and lost the post, anyway love you spybot team.

Always Confused
2007-07-27, 05:11
I shall endeavor to remember to restart before trying to immunize after the next update.

Of course, as my religion prohibits remembering things....

Always Confused
2007-07-27, 05:46
Weird: Purely out of curiosity, I just opened Spybot, went to the Immunization page.

There I found the same seventy-two Firefox un-immunized entries as I posted earlier today--yet the last time I ran Immunization, I was able to get all Firefox entries immunized. Thus, I have to wonder why I again had seventy-two entries not immunized.

Having found the 72, I ran immunization. The progress bar went part way across the screen, and then stopped, although the "building block" at the upper-left-hand corner kept on going.

So, I clicked on "check again", which worked--and which stated that all Firefox entries were immunized.

There seems to be a bit of a problem with the serum....

Addendum: I just found out that, while I could change from Immunize to other parts of Spybot (and update even worked) I could not close the program using the "X". I did not think to try File/exit. I had to use Task Manager, and there I found a repeat of earlier uses of Task Manager: I clicked on Spybot in Applications, then on End Task. Nothing happened, so I repeated the process, whereupon I got the notification that Spybot was not responding, and I was able to close Spybot through that pop-up.

2007-07-27, 13:25

Do you remember if you had Firefox/IE etc. open while trying to immunize?

Always Confused
2007-07-27, 14:17

Do you remember if you had Firefox/IE etc. open while trying to immunize?
Firefox was open; I'll try closing it first next time.

Always Confused
2007-07-27, 17:00
Okay, here are my latest findings:

1. I started Spybot and went into Immunization; the seventy-two Firefox files were again not immunized.

2. I closed Spybot, then I closed Firefox.

3. I restarted Spybot, went to Immunization.

4. The seventy-two files still not immunized, I ran immunization. Very quickly the seventy-two files were immunized. As soon as that happened, the progress bar stopped, approximately one-third of the way across from left to right. However, the "building blocks on the left side continued to run.

5. I tried to close Spybot using both the "X" and File/Exit. Neither worked. I again had to use Task Manager, and as previously, it took two tries to close Spybot, with the second attempt bringing up a "program is not responding" message.

6. I closed Spybot, opened Firefox; after perhaps ten minutes of browsing various sites, I reopened Spybot and checked immunization; as of now, all files, including those related to Firefox, have remained immunized.

2007-08-02, 06:32
1. Open firefox and view this forum
3. Launch Spybot the newest beta out on xp pro sp2
4. Go to the immunize page
5. Then go to the main page and click check for problems
6. Start a scan
7. go to the immunize page and click immunize
8. If nothing bad happens click redo then unimmunize (or whatever its called)
9. Will freeze or stop, and the cpu will be at 100% even on a 3.33 ghtz Celeron D, 512mb ddrII
10. Cant close spybot, tried system ctrlaltdel and cant end process, tried a few times, firefox is laggy now, spybot stil open, cant close it with file exit from within spybot.
11. It only just closed when i got to number 11

I know what you felt now.... Feel free tot ry it. :P

Always Confused
2007-08-02, 15:16
Something was changed with the latest updates to Spybot, which were released 1Aug07:

1. I closed Firefox, started Spybot, went into the update screen, checked the "beta test" box.

2. When the download of the updates was completed, a box (of the "commmand" nature) appeared on the screen. It disappeared too quickly for me to be able to note what it said; all I could gather was that it was, in fact, sending some sort of command to Spybot.

3. When the box closed, I was returned to the download updates screen; as the process was completed, I closed Spybot.

4. I then restarted Spybot and went into the Immunize module, which showed quite a few unimmunized entries, so I started the immunization process. The process took a while, but it did complete, and I was then able to close Spybot from within Spybot, rather than having to use the Windows Task Manager.

2007-08-02, 16:49
2. When the download of the updates was completed, a box (of the "commmand" nature) appeared on the screen. It disappeared too quickly for me to be able to note what it said; all I could gather was that it was, in fact, sending some sort of command to Spybot.

This is when it updated the TOOLS part. This is normal

I would try to UNimmunize everything, then go to TOOLS--> Host File--> REMOVE spybot host file list. Close client. Then restart then go to same play and ADD the host file list, then reimmunize everything. This should fix it all.

Always Confused
2007-08-02, 17:07
Hmm. WK357mag, did you read all of my latest posting in this thread, the message that stated that everything now works?

I don't see any reason to follow your instructions, although I'm sure they were offered in good faith. See the #4 entry in my posting earlier today, wherein I state that, for whatever reason (or even lack thereof), all seems to be working correctly.

2007-08-02, 17:12
I see that now. When I read it, I thought you were still having problems with this process.

I needed to do what I said, to get it all updated.

Good for you!

Always Confused
2007-08-02, 17:26
I had a thought; once I recovered from the shock....

What follows is totally hypothetical, and is offered here merely as a possibility:

I don't recall seeing the pop-up message during recent updates, and I know that, unlike this morning, I have not been returned from it to the download module of Spybot.

IF the pop-up did not appear (and, again, I don't know that it did not), then it is possible (and only possible) that SpySweeper has been interfering with recent Spybot updates.

Why would I say that? After an update to SpySweeper not too long ago, I started having serious problems with one of my many extensions to Firefox. My investigation led me to disabling the File System shield in SpySweeper, whereupon the extension problem went away.

I then filed a support ticket with WebRoot, SpySweeper's company, and quickly received a reply that they were aware of a problem with that shield and were working on a fix.

Yesterday, I got a notification of a new release of SpySweeper; when I installed that update, the problem with the Firefox extension was no longer there.

So, could SpySweeper have been at least part of the problems I've been having with Spybot? We'll never know, but it does seem to me to be at least within the realm of possibility.