View Full Version : Issue with Global (hosts)

2007-11-09, 12:44
I immunized my system including Global(hosts) which added over 6000 entries to my c:\winnt\system32\drivers\etc\hosts file. After this, I was getting abysmal performance from the Cisco VPN that I use to connect to my company's network. I restored the state of the hosts file to the state prior to doing the immunize, and the performance of the VPN is back to normal. For now, I have disabled immunizing Global(hosts). Is this a known problem? Is there a way to do this without having significant impact on other networking software?

md usa spybot fan
2007-11-09, 13:02
Blocking Unwanted Parasites with a Hosts File

Editors Note: in most cases a large HOSTS file (over 135 kb) tends to slow down the machine. This only occurs in W2000/XP/Vista. Windows 98 and ME are not affected.

To resolve this issue (manually) open the "Services Editor"

Start | Run (type) "services.msc" (no quotes)
Scroll down to "DNS Client", Right-click and select: Properties
Click the drop-down arrow for "Startup type"
Select: Manual, or Disabled (recommended) click Apply/Ok and restart. [more info (http://mvps.org/winhelp2002/services.htm)]

When set to Manual you can see that the above "Service" is not needed (after a little browsing) by opening the Services Editor again, scroll down to DNS Client and check the "Status" column. It should be blank, if it was needed it would show "Started" in that column. There are several Utilities that can reset the DNS Client for you ... [more info (http://mvps.org/winhelp2002/hosts.htm#Related)]