View Full Version : Update Problem with Spybot S&D 1.4

2005-11-17, 03:11
First off, I'm not new to Spybot S&D: been using it for a very longtime and through many of the version updates for years...and NEVER had this problem until a month ago...I can still update the definitions Manually from the Main website...just can't use Autoupdate to get them anymore... :(
I'm not sure if anyone's ran into this problem before or not..but I thought it was worth a try to ask if anyone had any Ideas on how to resolve this issue...This is what's happening...
1. Search for updates: No problem, retreives updates to be downloaded.
2. Choose a download site thats not so overloaded you can get the updates from: Again, no problem...
3. Click Download Updates: Problem...Cannot Open AVI
Huh? What's AVI?
I've even gone through the trouble Uninstalling, Deleting ALL Spybot entries in my Registry, and reinstalling the program from Scratch...yet I still get the Cannot Open AVI...:confused:
Thanks for anyone that can help...
Ideas??? Anyone

2005-11-17, 09:10
Problem...Cannot Open AVI
Huh? What's AVI?

AVI, an acronym for Audio Video Interleave, is a multimedia container format introduced by Microsoft in November 1992, as part of the Video for Windows technology. AVI files contain both audio and video data in a standard container that allows simultaneous playback. Most AVI files also use the file format extensions developed by the Matrox OpenDML group in February 1996. These files are supported by Microsoft, and are known unofficially as "AVI 2.0".


Someone may be able to provide assistance with the problem you are experiencing. Hang in there. :)

2005-11-20, 03:36
LOL...I know what AVI files are...hehe...Believe me, I'm not a Newbie when it comes to computers...I've even got College background training ...Too funny...
What I'm asking here is how do AVI files pertain to using SB S&D onboard update system...I can't see any relation, or why that message would popup trying to download updates...:rolleyes:
Looks like no-one has any Idea about this problem after 135 views...As I said it really doesn't matter that much to me because I can still update the definitions via the main website...I just like to trouble shoot problems with Windows (which happens more than they should...LOL) and resolve issues...The more you know, the better with WinBlows...LOL :p

2005-11-20, 22:03
Well... an AVI is in the window showing the update progress. That AVI comes with Windows. Well, with any Windows since 95 I guess ;)

But! Did you recently install some software? Software written in Microsoft Visual Basic is often packaged in an installer that is written in MS VB... and those installers tends to overwrite DLLs with the one from the installer, even if there's a new on the system and the installer one is stone old.

Not sure from here (will look up at work tomorrow), but I think it's in the comctl32 package... usually the version coming with Windows is sufficient, but you can probably update it here:

2005-11-21, 02:09
Yea...that's along the lines of thought I had... :)
The only "new" Software that would have any effect on that would be Nero Digital...I'll check into it...see if there's conflicts between that and visual basic 6
and I forgot to say I'm running Windows XP...yes, I know that does make a diff...Thanks...I think you nailed it on the head...I'll get it fixed and let you know how I resolved the issue... ;)

2005-11-21, 15:23
Well....For now I'm giving up on trying to resolve this onboard updating issue with SB S&D...Everything I've tried hasn't worked...Seems (according to MS) all the functions that pertain to AVI are already addressed updated and installed...:rolleyes:
I haven't found any other problems with any other programs (which is around 70gbs worth of software)...So for now I'm just going to let this one go...its just not that Crucial to my OS...I'll just have to check every month on the website for the Defenitions, and immunization updates and download and install them manually... ;)
But, if by chance I do run across the Fix for "Cannot open AVI", I'll be sure and post it here so that anyone else that runs into this problem will have the fix for it... :)
(I Googled this and there have been prior postings on this problem before with no resolve)