In zoon alarm if you go to Firewall on the left and then the main tab in the upper right then go down to the advance button and click on it your see under General setting "Lock Hosts file".
It works...