Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Immunization v2 preview

  1. #1
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default Immunization v2 preview

    Important: this is just a preview of what will appear integrated in Spybot-S&D 1.5. I decided to make it available as a teaser since I promised something for today Feedback is welcome, but "official beta feedback" is needed only once you got the updated full package (going to make that next).

    download link

    You need to extract this into an existing Spybot-S&D folder, since it needs the regular data files.

    I did already mention the features in another topic, so here's just a quick overview: much improved Opera support (Content-Filter and Cookie-Filter as well), new Firefox/Mozilla/SeaMonkey/etc. support, Hosts file usage integrated, display of details for each browser and category and more.

    A not really up-to-date screenshot, known from the other topic:
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Posts
    144

    Default

    WOOT WOOT

    Looking good man!!

  3. #3
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Downloaded ,unzipped, placed ImmunizeUIv2.exe in C:\Program Files\Spybot - Search & Destroy.

    Unblocked the file, double clicked to open: shows pic 1.
    I don't have Firefox, Opera or Mozilla so the fact it's not showing those is OK. But Nnotice all 0 under protected (Spybot's regular immunize shows all blocked).
    I have mvps.org HOSTS file, Spybot's not added.
    Clicking check or undo or immunize gives error box. clicking show bug report on that box gives pic 2.

    XP SP2, IE 7 all updates except .NET framework 3 (have 1.1 and 2). Spybot 1.5.1.12 last detection update 03/03/07. Tracks.uti currently renamed tracks.sbi so I can scan for tracks.
    Last edited by Rosenfeld; 2007-07-06 at 16:15.

  4. #4
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default

    Hmmm...

    That it's showing "0" at first is ok, you need to click the Check button once
    Integrated into Spybot, it'll automatically check when going to that page (just implemented ).

    The second one is difficult to guess from these very small screenshots (does the forum resize them?), but I do see one crash report from someone who has reported this, and it's probably the new animation I talked about that's not showing up:

    I'll improve loading of that animation, will be fixed in the integrated version
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  5. #5
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Sorry about the small size. I just took a screen shot of the window, did not shrink it at my end.

    Would you like me to send the bug report, or is that not functional in this demo?

    The bottom line does say cannot open avi. Is that avi internal to the .exe? no separate avi file is apparent.

  6. #6
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default

    It should have been internal, but I made a mistake in including it, that's why it worked in-house here, but not for you

    I'm now looking for another very small last-minute idea...
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  7. #7
    Member GT500's Avatar
    Join Date
    Nov 2005
    Location
    Indiana, USA
    Posts
    70

    Default

    Is this supposed to work in Vista? When I run it (with or without admin privileges) it doesn't work. I tried to send a bug report, but that doesn't work either. For reference, I'm using the x64 Vista.

    The issue occurs when I click the "Immunize" button (or the "Check Again" button, but I assume they are caused by the same problem). I made screenshots of everything since I couldn't send the error report:

    Main program window.

    First tab of bug report.

    Second tab of bug report.

    Third tab of bug report.

    Fourth tab of bug report.

    Fifth tab of bug report.

    Sixth tab of bug report.

    Seventh tab of bug report.

    Eighth tab of bug report.

    If you need any other info, then just let me know.

  8. #8
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Your bug report shows the same problem: cannot open avi. PepiMek has posted above yours that will be fixed in next release.

  9. #9
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default

    Just use the download link at the top again, it now contains preview 02

    In addition to the AVI fix, I also tested the skinning mechanism I'm going to implement (as an optional! feature) into main Spybot-S&D, e.g. here skinned in Windows Media Player style:

    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  10. #10
    Member GT500's Avatar
    Join Date
    Nov 2005
    Location
    Indiana, USA
    Posts
    70

    Default

    Thanks for the update. It works perfectly.

    I did notice that in Vista, it doesn't immunize against everything when running with normal user privileges. When I ran it as Administrator, it immunized against the rest of the items. Should this always be run as Administrator under Vista, or does it need to be run as a regular user as well?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •