Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: clean update 1.5.1.13 (language)

  1. #1
    Member
    Join Date
    Feb 2007
    Location
    Belgium
    Posts
    61

    Default clean update 1.5.1.13 (language)

    Hello,

    i receive ALL language in spite of i don't ask all language

  2. #2
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default

    Hmmm... let me take a look... you received all language files (but not help etc. in other languages)?

    Looks like it might be that the installer is not able to do an "or" operation on conditions. I made the installer itself multilingual, supporting nearly every language. For each file that may be installed, I can give two arguments:

    1. "install if languages selected"
    2. "install if user chose installation language X".

    Using the first, or both, wouldn't install it if the user selected his language during installation, but not the languages package. Using only the second would make the languages option useless. So currently I'm using none for those languages that are supported by the installer as well (the option just toggles additional files).

    I created an entry for this problem here
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  3. #3
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    I did a clean install of 1.5.1.13 (i.e. a prior uninstall of 1.5.1.12 and cleanup of all folders and registry entries).

    I also had languages unchecked during install, but have the languages folder with 51 .sbi files in it, so confirm benoit's findings.

    Also, I noticed a slightly odd behaviour relating to updates:

    During install I checked the box download updates immediately. It did indeed go and get them. There was a slightly confusing box asking me to select the folder where the updates were to be installed. I selected C:\Program Files\Spybot - Search & Destroy (which must already been created by the install, since I had taken care to delete it prior to clean install) and that seemed to be right, as the .sbi files showed up in the includes subfolder; but it might be helpful to indicate what folder one should be looking for (e.g. a note saying 'select the folder in which you have installed Spybot'), or better still arrange it to scan the drive to find the folder automatically.

    [EDIT: the box asking for the folder was the Windows one, showing explorer like tree structure and including the button option to create new folder; so this may be a Windows thing, that the download during install lacks info to tell Windows where to put the downloaded files?]

    Then, after completing the install, I checked for updates, and was surprised that it found and redownloaded all the updates it already had downloaded during the install, as well as the beta.sbi I had set it to look for and a few optional (unchecked) ones that one might reasonably expect not to be included in the essential updates downloaded during install, such as targets.nfo.

    Subsequent check for updates worked OK (i.e. it said no updates found).


    Otherwise looking good: tracks not showing bug fixed. Immunize new look screen allowing selection of categories to immunize works well.

    Still a few internals flagged as wrong uninstall path because Spybot apparently gets confused by command switches added after the path to the uninstall file, that some apps add to the uninstall line.

    XP SP2, IE 7, all updates.
    Last edited by Rosenfeld; 2007-07-13 at 12:54.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Posts
    144

    Default

    Quote Originally Posted by Rosenfeld View Post

    I also had languages unchecked during install, but have the languages folder with 51 .sbi files in it, so confirm benoit's findings.

    <snip>

    Otherwise looking good: tracks not showing bug fixed. Immunize new look screen allowing selection of categories to immunize works well.
    Language Files: I noticed this as well, but thought it to exspected. During the install I choose to NOT install the languages, as I dont need them. I actually uncheck all options during install, so, I dont even go check for updates during the install. I do this after. But these language files are all installed anyway. I do manually delete them, but guess they shouldnt be there. So I confirm this installer issue with these other two guys.

    Tracks bug is fixxed for me too.

    LOOOOOOVE the new Immunization screen!!!

    ANother thing: Not a real problem, but I notice a DELAY when opening a screen. Go to SETTINGS --> IGNOR PRODUCTS, when opening this screen, there is a delay here, that wasnt present in 1.4. This may be ok, just thought I should comment if there is no known reasons for it.

    My rig: WinXP (sp2) fully updated, P4c-3000@3500mhz, 1024mb ram Cas 2.5,3,3,7, 10,000rpm Raptor HD's

  5. #5
    Member
    Join Date
    Feb 2007
    Location
    Belgium
    Posts
    61

    Default

    Hello,

    the problem that I had mentioned about the selection of the items (update english language) that I do not want download is solved. Thanks.

    the language i have is french it's perfect but i don't need all the other.

    thanks

  6. #6
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Quote Originally Posted by wk357mag View Post

    ANother thing: Not a real problem, but I notice a DELAY when opening a screen. Go to SETTINGS --> IGNOR PRODUCTS, when opening this screen, there is a delay here, that wasnt present in 1.4. This may be ok, just thought I should comment if there is no known reasons for it.
    Don't get any dealay opening that screen here.

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Posts
    144

    Default

    at the point that I click that page, its takes 3 seconds to open it

  8. #8
    Member
    Join Date
    Feb 2007
    Location
    Belgium
    Posts
    61

    Default

    Quote Originally Posted by PepiMK View Post
    Hmmm... let me take a look... you received all language files (but not help etc. in other languages)?

    Looks like it might be that the installer is not able to do an "or" operation on conditions. I made the installer itself multilingual, supporting nearly every language. For each file that may be installed, I can give two arguments:

    1. "install if languages selected"
    2. "install if user chose installation language X".

    Using the first, or both, wouldn't install it if the user selected his language during installation, but not the languages package. Using only the second would make the languages option useless. So currently I'm using none for those languages that are supported by the installer as well (the option just toggles additional files).

    I created an entry for this problem here

    Hello,

    i see that you said it is fixed. If yes for me it's not fixed.

    i take the default installation 'personnalized' and i uncheck the language download and i have nevertheless all them.

  9. #9
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,579

    Default

    @benoit: If you click the link where I said it was fixed (the one in the link above), you should also see this line on the issue:
    Fixed Version 1.5.1.++ RC? (build 200707??)
    Since I assume you don't really have that version that doesn't even have a new version and build number yet, but only exists right here in my test environment, I'm not really suprised

    @wk357mag: I just tried and I experience a small delay as well, though probably only 1 second, and we have many more filesets internally. There actually is a way to make this appear immediate, and from a technical standpoint, it's quite easy to implement. The question would probably be though if it's worth the additional time (also for testing), I'll have to take a look where exactly this list is used and how its linked together with other stuff
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  10. #10
    Member
    Join Date
    Feb 2007
    Location
    Belgium
    Posts
    61

    Default

    [QUOTE=PepiMK;104199]@benoit: If you click the link where I said it was fixed (the one in the link above), you should also see this line on the issue:
    Since I assume you don't really have that version that doesn't even have a new version and build number yet, but only exists right here in my test environment, I'm not really suprised


    ok but it is also marked "fixed" ;-) i don't know wat are the rules to see a case is fixed or not.

    Title / Submitted Status Priority
    Installer always installs all language files Fixed 4


    Thanks for all wat you do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •