Results 1 to 7 of 7

Thread: sb 1.5.1 cant immunize host file

  1. #1
    Junior Member
    Join Date
    Sep 2007
    Posts
    1

    Default sb 1.5.1 cant immunize host file

    just uninstalled old version and installed 1.5.1,things seem 2b working ok apart from the above,when i try to immunize host list it says ,cannot access file because its being use by another,i presume something from the old sb is there,suggestions please,

  2. #2
    Spybot Advisor Team [Retired] md usa spybot fan's Avatar
    Join Date
    Oct 2005
    Posts
    5,859

    Default

    With Spybot 1.4 were you using Spybot's HOSTS file which was a seperate function and not intergrated into the immunization process?

    Are you running any other anti-malware programs besides Spybot-S&D that may be blocking access to the HOSTS file?

    ZoneAlarm, STOPzilla and possibly other programs can block access to the HOSTS.

    Getting an answer is one thing, learning is another.


    Microsoft Windows XP Home Edition running on a 2.40GHz Intel® Pentium® 4 Processor with 512 MB of RAM and a 533 MHz System Bus.

  3. #3
    Senior Member
    Join Date
    Oct 2005
    Location
    Potomac MD USA
    Posts
    119

    Default Same problem

    I too encountered this problem with 1.5. It did not exist with 1.4.
    Last week I stopped Spy Sweeper and Spybot updated Hosts file.
    This week, that did not work. I also have Grisoft AVG running.
    How does one determine the program that is using Hosts?
    I could not find it in the event logs.
    Thanks

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Potomac MD USA
    Posts
    119

    Default

    My Host file update worked today. I did NOT stop any security tools - Spy Sweeper or AVG. I checked the date/time of the Hosts file and it is correct.
    All's well that ends well.

  5. #5
    Junior Member
    Join Date
    Sep 2007
    Posts
    13

    Unhappy Host file immunization probs continue

    I'm running Spybot 1.5.1.15 on a Win 2K, with Avast antivirus with Comodo's Firewall and BOClean and Spyware Blaster.
    This is the second week in a row that the host file immunization has failed. Last week the manual method suggested by "MD USA Spybot Fan" worked for me.

    http://forums.spybot.info/showthread.php?t=18113

    But this week when I try to do it manually I get the message that I've seen elsewhere on the forum: "Process cannot access the file because it is being used by another process."

    Funny thing is that my security hasn't changed. I'm running the exact same stuff as I was last week when it let me add the file manually. I also turned off my Avast, BOClean and firewall and tried it that way, but still no good.

    The immunization has been (buggy) since v1.5 came out. The immunization has to be made to work better. (And get rid of the brick wall; it's kinda silly when it stops building before it's finished.)

    So I guess I'm gonna do a clean uninstall and re-install and see what happens, but if this keeps up for more than a couple of more updates, I'm gonna have to drop Spybot for a while, 'cos this is getting to be a nuisance.

  6. #6
    Junior Member
    Join Date
    Sep 2007
    Posts
    13

    Cool

    OK. A clean uninstall/reinstall changed nothing. Still incomplete host file immunization. However after downloading the update I went into safe mode and was able to immunize the host file manually as per the earlier advice.

    I hope this can get fixed on the Spybot end because finding what is keeping Spybot from accessing the file is beyond my ability.

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Potomac MD USA
    Posts
    119

    Default

    I run my Spybot scan each Sunday after updates. If there are updates, I redo the hosts file. Today the Hosts file update produced the message "Process cannot access the file because it is being used by another process." The Host file update seemed to complete in spite of this. It has today's date and time. It is also the size I would expect (210KB). So, is this a message to be ignored? It does seem to be intermittent for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •