Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [Solved] 1.5.1.18 "Erase using Spybot - Search & Destroy"

  1. #1
    Junior Member hpwamr's Avatar
    Join Date
    Sep 2007
    Location
    Belgium
    Posts
    21

    Question [Solved] 1.5.1.18 "Erase using Spybot - Search & Destroy"

    Hello PepiMK,

    Many thanks for this beta2. SSD 1.5.1.18 is working very smoothly

    I just don't understand the working of "Erase using Spybot - Search & Destroy" in the Windows Explorer.
    Because when I select a file in the explorer and then click on: "Erase using...." I always receive a popup box with this message "This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel."
    Is this a bug or do I something wrong ?

    Could you please give me a little bit more explanation.

    Thank you very much.

  2. #2
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,576

    Default

    Might really be something wrong in the installer, thanks for the report

    The tool itself is just to manually delete files that won't go away otherwise (more or less a delete function that's using the same techniques as Spybot-S&D to get rid of stubborn files).

    To fix it, you would have to open regedit, navigate to HKEY_CLASSES_ROOT\*\shell\sddelfile\command\, cut the name of the second value there and paste it as the data for the default value (it's usually "C:\Program Files\Spybot - Search & Destroy\SDDelFile.exe" "%1" /ask).
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  3. #3
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Thanks that fixed it for me.

  4. #4
    Junior Member hpwamr's Avatar
    Join Date
    Sep 2007
    Location
    Belgium
    Posts
    21

    Thumbs up

    PepiMK,
    Thank you for your prompt reply.
    Indeed it's something wrong with the key: :

    The "Default" value is staying "BLANK"
    And there are a new "String Value" with this incorrect Value Name: < "C:\Program Files\Spybot - Search & Destroy\SDDelFile.exe" "%1" /ask > and incorrect Value Data: < Erase using Spybot - Search && Destroy >

    Hereunder an export of this bad key:
    [HKEY_CLASSES_ROOT\*\Shell\sddelfile\command]
    "\"C:\\Program Files\\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"="Erase using Spybot - Search && Destroy"

    And YES, the "Erase using Spybot - Search & Destroy" is working as expected, when I delete the BAD Value and for the "Default" value, I replace the "BLANK" Data Value with: < "C:\Program Files\Spybot - Search & Destroy\SDDelFile.exe" "%1" /ask >.

    Thanks

  5. #5
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,576

    Default

    I've attached a zip with a .reg file to fix it, or here the repair-sddelfile.reg file content in plain text:

    For 64 bit systems its probably:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\sddelfile]
    @="Erase using Spybot - Search && Destroy"
    
    [HKEY_CLASSES_ROOT\*\shell\sddelfile\command]
    @="\"C:\\Program Files (x86)\\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"
    For 32 bit systems, it is:
    Code:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\sddelfile]
    @="Erase using Spybot - Search && Destroy"
    
    [HKEY_CLASSES_ROOT\*\shell\sddelfile\command]
    @="\"C:\\Program Files\\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"
    Just for those who may be reading this topic in the future who didn't understand my previous explanation
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  6. #6
    Junior Member
    Join Date
    Nov 2007
    Posts
    4

    Default

    Is there any purpose in using something as long as "Erase using Spybot - Search & Destroy"? It makes the context menu freaking huge. You should at least shorten it to something like "Erase using Spybot".

  7. #7
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,576

    Default

    I have a bunch of entries of a similar length, but that might be because German entries tend to be longer anyway and my systems are usually mixed ones

    Shortened it to "Erase using Spybot-S&D", and please keep in mind that I'm not sure if it makes its way into the final release anyway
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  8. #8
    Esteemed Member
    Join Date
    Oct 2005
    Posts
    211

    Default

    Yopu can change it to whatever you like, just modify the data string for default value of

    HKEY_CLASSES_ROOT\*\shell\sddelfile

  9. #9
    Junior Member hpwamr's Avatar
    Join Date
    Sep 2007
    Location
    Belgium
    Posts
    21

    Default

    Quote Originally Posted by PepiMK View Post
    [HKEY_CLASSES_ROOT\*\shell\sddelfile]
    @="Erase using Spybot - Search && Destroy"

    [HKEY_CLASSES_ROOT\*\shell\sddelfile\command]
    @="\"C:\\Program Files (x86)\\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"[/code]
    Hello PepiMK,

    Juste For Your Iinformation,

    CCleaner V2.0.527 is trying to remove this add reg code with as Probem Description: 'Open with Application Issue"

    Have a nice WE.

  10. #10
    Member
    Join Date
    Oct 2007
    Location
    Aquitaine
    Posts
    32

    Default

    Hello,

    I did not have good work (on my win xp sp2 home) with that new key given by PepiMK :

    "C:\\Program Files (x86)\\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"

    I have put this one :

    "C:\\Program Files\Spybot - Search & Destroy\\SDDelFile.exe\" \"%1\" /ask"

    And now all is working fine to erase !!!

    Nota Bene : to hpwamr : with that modification, CCleaner V2.0.527 is not trying to remove this add reg code !!!

    Sorry for my bad english, but I am french ...
    Last edited by Asus L3500TP; 2007-11-26 at 01:34. Reason: Not Bene : for hpwamr
    @+

    A vida não se resume em festivais (G.Vandré)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •