Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Disable "Allow paste operation via script"

  1. #1
    Member of Team Spybot tashi's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    30,485

    Default Disable "Allow paste operation via script"

    Quote Originally Posted by AplusWebMaster
    To fix this it is simple, do the following in your browser:
    Tools->Internet Options->Security->Custom Level scroll down to "Scripting"
    Disable "Allow paste operation via script"
    Hit OK and you should be good to go.

    To verify, repeat step 1 & 2 and you will see the link can not see your clipboard.
    That fix did not work for me.
    Microsoft MVP Reconnect 2018-
    Windows Insider MVP 2016-2018
    Microsoft Consumer Security MVP 2006-2016

  2. #2
    Spybot Advisor Team [Retired] md usa spybot fan's Avatar
    Join Date
    Oct 2005
    Posts
    5,859

    Default

    It appears to have worked for me:

    Windows XP (Home) SP2 (WinNT 5.01.2600)
    Internet Explorer v6.00 SP2 (6.00.2900.2180)

    Getting an answer is one thing, learning is another.


    Microsoft Windows XP Home Edition running on a 2.40GHz Intel® Pentium® 4 Processor with 512 MB of RAM and a 533 MHz System Bus.

  3. #3
    Member of Team Spybot tashi's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    30,485

    Default

    Odd.
    WARNING, TEXT RETRIEVED: (see below)

    So try this: 1) Copy any text by ctrl+c 2) Click the Link:
    Windows XP (Pro) SP2 (WinNT 5.01.2600)
    MSIE: Internet Explorer v6.00 SP2 (6.00.2900.2180)

    I was trying out IE7 Beta; returned to IE6 but the fix did not work on either.
    Microsoft MVP Reconnect 2018-
    Windows Insider MVP 2016-2018
    Microsoft Consumer Security MVP 2006-2016

  4. #4
    Spybot Advisor Team [Retired] md usa spybot fan's Avatar
    Join Date
    Oct 2005
    Posts
    5,859

    Default

    After modifying setting:
    • "Scripting"
      • "Allow paste operation via script" from "Enable" to "Disable"

    When I copy to the clipboard (Ctrl + C) and the going to the following link:
    I get:

    No text found in clipboard. This is a good thing!

    Works with Internet Explorer and Netscape.
    If I set it back to "Enable" I get"

    WARNING, TEXT RETRIEVED: (see below)
    Make sure that you are doing it for each security zone although:
    1. My Restricted zone was already set that way.
      --- and ---
    2. The www.sourcecodesworld.com site should be in the Internet zone (it is on my system), which is the default zone when you go into the Security tab in Internet options.

    Getting an answer is one thing, learning is another.


    Microsoft Windows XP Home Edition running on a 2.40GHz Intel® Pentium® 4 Processor with 512 MB of RAM and a 533 MHz System Bus.

  5. #5
    Member of Team Spybot tashi's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    30,485

    Default

    Quote Originally Posted by md usa spybot fan
    Make sure that you are doing it for each security zone although:
    That did it, thanks. Silly me. :D
    Microsoft MVP Reconnect 2018-
    Windows Insider MVP 2016-2018
    Microsoft Consumer Security MVP 2006-2016

  6. #6
    Member of Team Spybot tashi's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    30,485
    Microsoft MVP Reconnect 2018-
    Windows Insider MVP 2016-2018
    Microsoft Consumer Security MVP 2006-2016

  7. #7
    Former Microsoft MVP (RIP) siljaline's Avatar
    Join Date
    Oct 2005
    Location
    Montréal, Canada
    Posts
    50

    Wink

    Try these Settings

    Silj

  8. #8
    Member of Team Spybot tashi's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    30,485

    Default

    Thank you siljaline.

    Also members can find links in this topic:
    Have you updated Windows? Security Programs? Links and Tips.
    Microsoft MVP Reconnect 2018-
    Windows Insider MVP 2016-2018
    Microsoft Consumer Security MVP 2006-2016

  9. #9
    Former Microsoft MVP (RIP) siljaline's Avatar
    Join Date
    Oct 2005
    Location
    Montréal, Canada
    Posts
    50

    Cool

    Quote Originally Posted by tashi
    Thank you siljaline.

    Also members can find links in this topic:
    Have you updated Windows? Security Programs? Links and Tips.
    Your welcome, Tashi

    Great Security Teak for IE, that Setting

    Regards,

    Silj

  10. #10
    Adviser Team AplusWebMaster's Avatar
    Join Date
    Oct 2005
    Location
    USA
    Posts
    6,881

    Exclamation

    Despite setting the same corollary setting in IEv7 (now called "Allow Programmatic clipboard access" instead of "Allow paste operations via script"), the test -fails-, although it doesn't actually show what was copied from the clipboard (my results, anyway ~ Anyone else care to verify?).

    It would appear there is a bug (horrors!) in the new IEv7 (fully patched - includes all MS patches issued 11.14.2006).

    Same test link still available: http://www.sourcecodesworld.com/special/clipboard.asp but it is now LOADED with ad's (ugh!).

    For the moment, it would appear the best resolution is found at that site:
    "The best way to solve this problem is to use Firefox..."

    .
    Last edited by AplusWebMaster; 2006-11-16 at 18:40.
    The machine has no brain.
    ......... Use your own.
    Browser check for updates here.
    YOU need to defend against -all- vulnerabilities.
    Hacks only need to find -1- to get in...
    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •