Results 1 to 8 of 8

Thread: Deleted Background Options. Please Help!

  1. #1
    Junior Member JasonP27's Avatar
    Join Date
    Nov 2005
    Location
    Lancaster, PA
    Posts
    3

    Exclamation Deleted Background Options. Please Help!

    I have Windows XP Professional (No Service Packs). I ran Spybot S&D and found some registry entries to be removed, one called "Desktop.Explorer" and the other "Desktop.ActiveDesktop."

    When I removed them I lost the ability to change the background on my desktop, along with the entire "Desktop" tab in the desktop Properties window.

    I tried to recover them within Spybot, (the entries were in the recovery list,) but doing so did not (completely) fix or restore the computer's "Desktop" tab in the "Properties" window. (The tab came back, but everything is grayed out.)

    It may be possible that the entries were (partially) restored, because I have the Desktop tab back now, but I cannot change any of the settings in the Desktop tab. Also the Active Desktop tab is missing when I click the "Customize My Desktop" button.

    I recently saw a post about Desktop.Explorer being a false positive, but there is no solution to fix any problems caused by removing them.

    I tried System Restore, nothing. I even tried an in-place upgrade of Windows XP Professional, which didn't help either. It's as if the permission or right to change the background of the desktop has been denied by Windows itself, so I looked under the Local Security Policy etc. but did not find any options for display properties and the rights to change them.

    I've attached a picture of the Display Properties box with the problems clearly marked so there is no confusion.

    PLEASE HELP!
    Last edited by JasonP27; 2005-11-09 at 04:20.

  2. #2
    Junior Member
    Join Date
    Nov 2005
    Posts
    21

    Default Re-install graphics drivers

    Have you tried re-installing you graphic card drivers?

    Just a thought.

    You could also try removing your graphics card drivers altogether so that windows defaults back to its own VGA drivers (thus putting fresh registry entries back in?)

    Hope this helps.

  3. #3
    Security Expert-Emeritus
    Join Date
    Oct 2005
    Posts
    5,025

    Default

    Hi Jason
    Are you comfortable looking in the registry to see what the dword is for the
    NoActiveDesktop entry at both these locations ?
    http://www.winguides.com/registry/display.php/508/

  4. #4
    Junior Member JasonP27's Avatar
    Join Date
    Nov 2005
    Location
    Lancaster, PA
    Posts
    3

    Question

    Quote Originally Posted by LonnyRJones
    Hi Jason
    Are you comfortable looking in the registry to see what the dword is for the
    NoActiveDesktop entry at both these locations ?
    http://www.winguides.com/registry/display.php/508/
    Well there are not DWORD entries, the entries are set as REG_BINARY

    {NoActiveDesktop - REG_BINARY - 00 00 00 00}

    Should I change them to DWORD entries?

    Quote Originally Posted by murdo
    Have you tried re-installing you graphic card drivers?
    Yes, I had to after I did the in-place upgrade of Windows. So I'm sure I have the lastest drivers. It has to be something in the registry. I just don't know what entries are missing/not configured correctly.
    Last edited by JasonP27; 2005-11-10 at 01:31.

  5. #5
    Junior Member JasonP27's Avatar
    Join Date
    Nov 2005
    Location
    Lancaster, PA
    Posts
    3

    Thumbs up Whammo!

    HEY! I fixed it! I changed the NoActiveDesktop to a DWORD registry entry

    [CurrentVersion\Policies\Explorer\NoActiveDesktop]

    AND,

    [Policies\ActiveDesktop\NoChangingWallpaper] to a DWORD entry (it was REG_SZ)

    then I opened taskmanager, unloaded explorer.exe, reloaded explorer.exe, and WHAMMO! I can change the background!

    thank you thank you thank you thank you THANK YOU! :D

  6. #6
    Security Expert-Emeritus
    Join Date
    Oct 2005
    Posts
    5,025

    Default

    Hi

    Its odd that writeup speak's of a dword,. my system at that spot is also a binary, I did doublecheck it and added a 1 to make sure it was what couses the web tab to not be there,

    "I have Windows XP Professional (No Service Packs)."

    Please do go get them all

  7. #7
    Junior Member
    Join Date
    Nov 2005
    Posts
    1

    Thumbs up Booyah :D FIXED

    I had the same problem till I read this :D THANKS!

    With mine I only had to change;HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop\NoChangingWallpaper from a REG_SZ to a DWORD entry by deleting the entry and putting a new dword entry in of the same name.

    The other entry was already DWORD

    Anyhoo, all is well :D

  8. #8
    Junior Member
    Join Date
    Jun 2007
    Posts
    1

    Exclamation Help I Am Unabled To Use My Desktop Background Feature

    Help I Am Unabled To Use My Desktop Background Feature, It Is Totaly Grayed Out, I Have Windows Xp Home Edition, Please Can Somone Help And Give Me Step By Step Instructions On How To Get It Back

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •