Results 1 to 4 of 4

Thread: Computer crashed because of SB&D -> Update needed

  1. #1
    Junior Member
    Join Date
    Aug 2008
    Posts
    2

    Thumbs up Computer crashed because of SB&D -> Update needed

    Hi

    I have a SC, no Dual Core. If Sb&D is starting his check, the computer runns about 30min at 100% CPU and then the heating control switches the Notebook off immediately.
    I can not do the Sb&D Test to the end because of that.
    I'm a software engineer. I know, with the simple command "Threading.Thread.Sleep(1)" the problem is solved.
    Perhaps optionally by hidden function parameter or something like "Auto detect cores". But I can no more use Sb&D since a while because of that.

    Regards

    Timo

  2. #2
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,574

    Default

    Sleep? Sleep is evil
    If at all, delays should be done using WaitForSingleObject.

    But! For delays to cool down the CPU, they need to be that substantial that the scan slowdown would be noticable. And for the 99,5% of machines that have a "proper" heating, that would not be fair.

    Maybe an undocumented registry tweak could be done...
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

  3. #3
    Senior Member DougCuk's Avatar
    Join Date
    Oct 2005
    Location
    London UK
    Posts
    143

    Default

    You are a software engineer and want a software solution - I'm more of a general/harware engineer so maybe I tend to take a more general approach to this type of problem.

    I suggest you have a problem with your Notebook cooling system - as it is unable to run at 100% CPU for more than 30 mins without overheating and shutting down. You could no doubt trigger the same problem from any number of programs that imposed the same level of CPU loading - AntiVirus, Defrag, Video conversion.

    I suppose you could try setting the "Scan Priority" in Spybot down from the default to a lower setting which might reduce the CPU load. Maybe combined with a low load task to force load sharing - a screen saver maybe.

    But it sounds as if you really need to improve your CPU cooling. Often the safety margin built into the cooling systems of laptops is very minimal and you can go from ok cooling and overheating with very little restriction in airflow.

    Have you checked for fluff blocking the cooling vents, radiator fins and fan housing inside the laptop? I recently cleared out several laptop cooling systems that were clogged with fluff and pet hair - often caused by using laptops on soft surfaces. One was so bad that the system barely booted before it overheated and shutdown.

  4. #4
    Member of Team Spybot PepiMK's Avatar
    Join Date
    Oct 2005
    Location
    Planet Earth
    Posts
    3,574

    Default

    While I fully agree with DougCuk that the hardware should be able to deal with 100% for a long time (just imagine how many notebooks are "misused" for heavy duty gaming these days, running 100% CPU plus 100% GPU for more than just 30 minutes); anyway, I've added an inofficial tweak, see this wiki page
    Just remember, love is life, and hate is living death.
    Treat your life for what it's worth, and live for every breath
    (Black Sabbath: A National Acrobat)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •