Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: help me Stop spybot from overiding my settings in folder options and scanning files

  1. #11
    Senior Member drragostea's Avatar
    Join Date
    Jan 2008
    Location
    @Home
    Posts
    3,674

    Default

    It's not blasted nor is screwed up. I think there is a registry tweak that'll disable this right click scanning (you might as well read this post by spybotsandra: http://forums.spybot.info/showpost.p...23&postcount=2).

  2. #12
    Junior Member
    Join Date
    May 2009
    Location
    North Hollyweird, CA
    Posts
    12

    Default

    Hi slickrcbd,

    If I understand your problem, it's that you don't want SBS&D to scan everything when you open a program, correct?

    If so, try this: Open SBS&D and on the left are the menu options. Click on "Settings" and in the right pane scroll down to System Start and uncheck everything in there except: "No Automation".

    You might want to have a look at "Main Settings" while you're scrolling to the above and make sure "Save Settings" is ticked.

    Please post back if this helped.

  3. #13
    Junior Member
    Join Date
    May 2009
    Location
    North Hollyweird, CA
    Posts
    12

    Default

    I forgot to add: Have a look in "Program Start" while you're scrolling and try un-checking everything.

  4. #14
    Junior Member
    Join Date
    May 2009
    Posts
    10

    Default

    Quote Originally Posted by drragostea View Post
    It's not blasted nor is screwed up. I think there is a registry tweak that'll disable this right click scanning (you might as well read this post by spybotsandra: http://forums.spybot.info/showpost.p...23&postcount=2).
    I don't understand why you and others keep telling me how to disable right-click scanning when that isn't the problem. The context menu is fine the way it is, it's the double-click scanning that is the problem. Forgive me if I am getting frustrated as I don't know how to express this any clearer:

    I DO NOT want to disable right-click scanning.
    I want to disable double-click scanning, especially when it decides to scan a file instead of launching the application specified under Start->Settings->Folder Option... in Windows 98SE.

    In short, Spybot should only scan files by starting the main program from the start menu, or right-clicking on the file and choosing "Scan using Spybot Search & Destroy". It should never scan a file because I double-clicked on it, which goes double for file extensions I've previously set up to launch specific applications and quadruple for shift-clicking on said file and choosing the app I want, only to have Spybot's stupid scanner launch instead regardless of what I choose from the menu. Although the last behavior has only been observed with .SPL files, which I've triple checked the setup for. Even deleted and recreated it.

    I also, when presented with an unknown file type, I want to be asked what to do with it as per standard Windows 98 behavior. I don't want Spybot to run a useless scan. Most of the time it's because I made a typo when naming or renaming the file. Once when I first download the file is enough. Especially since Spybot pretty much locks up my 1ghz computer for up to a minute to run the scan.

    I have Windows 98 installed on this computer for a reason, so upgrading to something NT based isn't an option.


    jpChris
    All options you mentioned are already cleared.
    Last edited by slickrcbd; 2009-05-12 at 22:45.

  5. #15
    Senior Member drragostea's Avatar
    Join Date
    Jan 2008
    Location
    @Home
    Posts
    3,674

    Default

    Then perhaps another member can have a possible solution. As you I told you before your situation of having Windows recognize the correct program to open the file with but at the same time scan a file whenever you want is not likely, if it's even possible. Spybot+Windows OS=not physic.
    How do I configure Spybot to NEVER automatically scan a file, but only do so when I explicitly tell it to from the context menu?
    This is going into a circle. If you do not like my situation, just hope another possible solution passes by.
    What I want is to turn off that automatic scanning completely.
    Spybot's Shell scanner opens because the program assigned to open that particular file is either broken or missing. If you do not have the scanner installed in the first place, Windows will eventually ask you to pick from the list.

    I told you already that this could possibly be resolved without disabling the Shell scanner if you manually assign the file type, you are having a problem with, with the program that is necessary to open that kind of file.
    Spybot should NOT automatically scan a file when I try to open an Infinity Engine .SPL file, it should launch TeamBG's Spellmaker.
    Then manually assign that program to open that file then, and get it over with!

    Like you said, I don't know how I can explain this clearer.

  6. #16
    Junior Member
    Join Date
    May 2009
    Location
    North Hollyweird, CA
    Posts
    12

    Default

    Hi slickrcbd,

    Thanks for the post-back on unchecking.

    Now, it seems the only program you're having the problem with at this time is your .SPL program(s), correct? And, you've already right-clicked the .SPL program and checked the box, "Always use the selected program . . .", but it made no difference, correct? Every time you right-click on the program and select Open With, the program is highlighted and the first thing listed in the box is your program and no other, correct?

    Then you need to find out from someone here how to add .SPL to the "Ignore File Extension" or "Ignore Products" list and check it. Methinks SBS&D thinks this extension is a bug and not a program.

    Then, again, I could be wrong.
    Last edited by jpChris; 2009-05-13 at 05:14.

  7. #17
    Senior Member
    Join Date
    Oct 2005
    Posts
    202

    Default

    Sorry guys that I have to interrupt you. Drragostea has already said it: This is going into a circle. It seems that we have a communication problem here.

    I like the way how jpChris is trying to find out what slickrcbd really wants and how he is also trying to narrow the reasons of the problem.Good work! Trying to get a feedback is the best way to confirm that the information have been exchanged correctly(Friedemann Schulz von Thun model).

    @slickrcbd
    I suppose you normally know how to assign the default program for a file extensions but it didn't work. Is this correct?

    Start->Settings->Folder Option... in Windows 98SE.
    There could be several reasons for this. Spybot S&D makes many changes in the registry and so it may be necessary that you have to check the registry yourself. Do you have any experiences with editing the registry? Apart from that, was the Teatimer activated?
    http://www.safer-networking.org/en/faq/33.html
    I'm not sure if the Teatimer monitors the registry entries for the shell but if it does then it could block your change for the the default program. So you should try to turn it off first if it is activated.

    The registry is very complicated and some entries could make troubles if it is not used correctly as you can see in your situation. My suggestion for you is to read the article from the links below in the hope that it will help you to understand the problem and how to fix the problem.

    Part 1:
    http://articles.techrepublic.com.com...1-1046838.html

    Part 2:
    http://articles.techrepublic.com.com...1-1046840.html

  8. #18
    Senior Member 129260's Avatar
    Join Date
    Sep 2007
    Location
    Somewhere in the USA
    Posts
    1,139

    Lightbulb I think i have some light to shed on this....

    I have helped someone with this issue a long time ago in another thread found here.

    The problem is this:

    http://forums.spybot.info/showpost.p...17&postcount=7

    http://forums.spybot.info/showpost.p...26&postcount=8

    Keep things simple guys Don't make the issue harder then it is. No registry "hack" or anything needs to be done here. It is just a simple matter of a confused file association.

    @slickrcbd, please let me know if this helped.
    Last edited by 129260; 2009-05-13 at 15:43.
    "I am learning just like everyone else"
    new members!
    Custom built PC. Windows 7 pro x64 16GB Ram
    AMD FX 8 core 8350 Black edition
    SABERTOOTH 990FX/GEN3 R2.0
    Asus HD 7870 2GB GDDR5

  9. #19
    Junior Member
    Join Date
    May 2009
    Location
    North Hollyweird, CA
    Posts
    12

    Default

    @chi-va,

    Thanks. It looks like me 'n 129260 are on the same page.

  10. #20
    Senior Member
    Join Date
    Oct 2005
    Posts
    202

    Default

    @jpChris

    129260 is right about the confused file association but I'm not sure if he has read all of the posts and my posted links. The first part of the article isn't about a registry "hack". So I would recommend to read the article because it also recommends alternative fixing solutions apart from editing the registry.

    As you can see in the quotes slickrcbd has already done something similar to what 129260 is suggesting. So it seems he needs more alternatives.

    slickrcbd, is this correct?

    Post #3

    What I want is to turn off that automatic scanning completely. I only want it to scan a single file when I tell it to do so by right clicking on it like it did in the old version. If I have to dig out my backup CD where I saved the old version, so be it. Spybot should NOT automatically scan a file when I try to open an Infinity Engine .SPL file, it should launch TeamBG's Spellmaker. According to the file types tab under folder options in Windows, it is properly defined to do so. It did so before I "upgraded" Spybot with the "Important" patch.

    There were at least two other file types that it was doing this for last night, but I can't recall which ones exactly. It shouldn't matter, because it shouldn't be doing this at all. I want the "feature" turned off so that Spybot only scans a file when I right click on it and choose "Scan using Spybot-Search and Destroy", NEVER automatically, and it certainly shouldn't override the settings to launch a program I specified myself in Windows. I don't have a clue how to tell Spybot that, and I really don't want to have to enter the info in twice.

    Post #10
    Ok, I reverted back to version 1.6.0. That has fixed some of the problems. However, whenever I double-click on an Infinity Engine spell file (.SPL) SpyBot opens and scans the file. It also scans unknown files. The older version I was using didn't do that, but instead presented me with a list of things to open.

    I've tried shift-right clicking on the .spl file and doing "open with", but regardless of what I choose, SPybot scans the file instead of Windows opening the program I choose. This is very frustrating, as I'm working on a mod for BG2 and don't want to install it on my new computer when it runs just fine on my old computer.

    While I do want to be able to right-click to scan a file, I want this "feature" of overriding my settings for the open command in folder options gone. What older version do I need to find to remove the auto-scanning completely?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •