Results 1 to 3 of 3

Thread: "Access Denied" when trying to fix problems

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    3

    Default "Access Denied" when trying to fix problems

    I got an "unexpected error trying to fix problems" message. Spybot S & D could not access the file C:\Windows\System32\..\hosts saying "Access Denied". I tried using 'My Computer' to change the properties and remove the "Hidden" from the folder and all sub-folders, but ran into the same thing. If I click on "Retry" nothing happens. If I click on "Ignore All" it seems to change everything, but opening properties again on the C:\Windows folder shows that it is still Hidden.

    Does anyone know how to get around this?

    Thank You,
    Roger

  2. #2
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,172

    Default

    Files being hidden shouldn't affect that.

    A couple questions,they might help to find out what might be going on.(So don't just think I'm an awfully nosy person.)
    What operating system are you using(Windows 7,Vista,XP,Etc.)?
    Do you have Zone Alarm firewall?

    Could you run a 'Check for Problems' scan,and when it's done,rightclick somewhere in the results window and select Copy results to clipboard,then paste the results here?

  3. #3
    Senior Member
    Join Date
    Oct 2005
    Location
    Germany
    Posts
    5,263

    Default

    Hello,

    That is due to an infection.
    Please delete your old host file.
    Where the hosts file is located depends on your Windows version.
    Windows 2000/XP/NT: C:\windows\system32\drivers\etc
    Windows 95/98: C:\windows\hosts

    Then download a new host file on this site.

    Copy the whole text.
    Then create a new txt file on your desktop and name it hosts without any extensions.
    Then paste the text into it and store the file at the same place like mentioned above.

    To enable the viewing of Hidden files follow these steps:
    1. Close all programs so that you are at your desktop.
    2. Double-click on the My Computer icon.
    3. Select the Tools menu and click Folder Options.
    4. After the new window appears select the View tab.
    5. Put a checkmark in the checkbox labeled Display the contents of system folders.
    6. Under the Hidden files and folders section select the radio button labeled Show hidden files and folders.
    7. Remove the checkmark from the checkbox labeled Hide file extensions for known file types.
    8. Remove the checkmark from the checkbox labeled Hide protected operating system files.
    9. Press the Apply button and then the OK button and shutdown My Computer.
    10. Now your computer is configured to show all hidden files.

    Or have a look at this page to see how to show hidden files and folders.

    Best regards
    Sandra
    Team Spybot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •