Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: What Forum should I ask about SDONACCESS.exe? Why so many are running concurrently.

  1. #1
    Junior Member
    Join Date
    Dec 2013
    Posts
    2

    Default What Forum should I ask about SDONACCESS.exe? Why so many are running concurrently.

    Hello.
    I am not that familiar with the forums and don't know where I should search for or ask this question.
    Let me know and I'll take my post there.

    I have SpyBot Home edition.
    Here is my issue.
    Every so often my system just bogs down, CPU is a 100%.
    I go to task manager to see what processes are running.
    One time I had over 50 SDONACCESS.exe running!
    What the heck is that all about? I understand it is a Spybot process.
    Can someone point me to a post that might talk about that and what it is?
    Or tell me what it is and whether that is my problem.
    I can understand a few of them running, but why so many?
    Then after a while, they go away, and my system get back to normal, sort of.
    It just stalls my browser to a standstill.
    I don't know if it is SDONACCESS.exe or not that is causing my slow down.
    Can someone help me out here?
    Thanks ... Bob

  2. #2
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,173

    Default

    I couldn't find any posts on the forum directly talking about SDONACCESS.exe.
    I'm not entirely sure what it is.
    About the only thing I found was that it's description is On Access protection dialog.
    Perhaps it is related to live protection somehow,though I'm not at all sure on that.

  3. #3
    Junior Member
    Join Date
    Dec 2013
    Posts
    2

    Default

    I too could find nothing on search.
    It hasn't happened for a few days now, so I don't know what it was.
    Is there anywhere that I can address SpyBot directly to ask about it?
    Or do they have folks monitor this forum?
    If so, I've had no response.
    Oh well.
    Maybe rebuild again and see if that helps.
    Thanks
    Bob

  4. #4
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,173

    Default

    Yes,you certainly can ask them directly.There is a form for Home and Professional support here:
    http://www.safer-networking.org/cont...edition-users/
    Good luck,I hope you get it sorted.

  5. #5
    Junior Member
    Join Date
    Feb 2014
    Posts
    1

    Default SDONACCESS.EXE - I have the same problem with so many running in my memory!!!

    Bob - I have the same exact problem. I'll look into what's taking up my CPU and I'll see 50 SDONACCESS.EXE running out of control. I'm forced to shut the system down and reboot. I don't even know what this execute file does and why the system wants to have so many running at once. I'm glad someone else is experiencing this problem besides me.




    Quote Originally Posted by EagleBrewing View Post
    Hello.
    I am not that familiar with the forums and don't know where I should search for or ask this question.
    Let me know and I'll take my post there.

    I have SpyBot Home edition.
    Here is my issue.
    Every so often my system just bogs down, CPU is a 100%.
    I go to task manager to see what processes are running.
    One time I had over 50 SDONACCESS.exe running!
    What the heck is that all about? I understand it is a Spybot process.
    Can someone point me to a post that might talk about that and what it is?
    Or tell me what it is and whether that is my problem.
    I can understand a few of them running, but why so many?
    Then after a while, they go away, and my system get back to normal, sort of.
    It just stalls my browser to a standstill.
    I don't know if it is SDONACCESS.exe or not that is causing my slow down.
    Can someone help me out here?
    Thanks ... Bob

  6. #6
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,173

    Default

    I think I found it finally.It looks like it's for the MRU scan scheduled task:
    "C:\Program Files (x86)\Spybot - Search & Destroy 2\SDOnAccess.exe"
    The description in scheduled tasks is - Background scan of most recently used files when the computer is idle.
    Do you have that scheduled?
    It would be at Spybot start center,checkmark advanced mode,click Settings(say yes to the UAC prompt,if applicable),click the Schedule tab.If task is enabled,then the add button should be greyed out.

  7. #7
    Junior Member
    Join Date
    Feb 2014
    Posts
    2

    Default

    Quote Originally Posted by Zenobia View Post
    I think I found it finally.It looks like it's for the MRU scan scheduled task:
    "C:\Program Files (x86)\Spybot - Search & Destroy 2\SDOnAccess.exe"
    The description in scheduled tasks is - Background scan of most recently used files when the computer is idle.
    Do you have that scheduled?
    It would be at Spybot start center,checkmark advanced mode,click Settings(say yes to the UAC prompt,if applicable),click the Schedule tab.If task is enabled,then the add button should be greyed out.
    I've had the same problem - this is really a drag on my system. When I looked where you suggested the ADD button was not greyed out - so it's not activated.

    Here's what I did find: Settings/System Services and a Scanner Service there described in part as "scanning during on-access."

    I'm going to STOP it and see if that helps. Then though I don't know how important that loss of protection will be.

    Cane

  8. #8
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,173

    Default

    I looked in services,and a further description in there,to go along with the one in Spybot itself for Scanner Service is:"Offers malware scanning services to Spybot-S&D modules."Though to be truthful I'm not entirely sure what that means.I tried going to C:\Program Files (x86)\Spybot - Search & Destroy 2\SDFSSvc.exe and doubleclicking it,but all it really did was ask for permission to run with UAC and then run in my task manager,and I never hit the right thing to get a reaction from it.

    If I find out what it is,I'll post it here.

  9. #9
    Junior Member
    Join Date
    Mar 2014
    Posts
    1

    Default SDOnAccess.exe killing my machine too

    I am also suffering from this SDOnAccess.exe memory hog and would love to know how to stop it.

    Disabling all scheduled scans has made no difference.

    Currently the only solution I have found that works is to reboot my laptop 1 or 2 times a day when this occurs.

  10. #10
    Junior Member
    Join Date
    Apr 2014
    Posts
    1

    Default

    I too am getting this on my workstation. I've only had S&D +AV for a weeks as I was getting tired with AVG. Only way I can 'recover' my system is to hard reset - not good on a company workstation!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •