Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Runtime error 217 at 500E8338

  1. #1
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default Runtime error 217 at 500E8338

    I am running Spybot S&D 2.4.40 on Windows 8.1. I consistently receive a Runtime error 217 at 500E8338 upon system boot. I uninstalled Spybot, rebooted, and did not receive the error. I have performed this procedure twice with the same results. I reloaded Spybot in safemode, performed a complete system scan, and rebooted. Once again, I received the same runtime error. Please help.

  2. #2
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,337

    Default

    Which edition of Spybot do you have,free,home,pro?
    If you could locate the error in Event Viewer,that should give you more info about it.There are starting event viewer instructions for Windows 8 when you scroll down on this site,if you need them:
    https://www.winhelp.us/event-viewer-in-windows.html
    When you locate the error,if you doubleclick it,there should be a Copy button at the bottom.Could you please paste it here?

  3. #3
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default Windows Defender Won't Start

    I'm not sure if this is related to the Runtime error, but what I found seems to be more serious. I have thousands of errors involving the Windows Defender trying to start, but not able to. Below is a copy of one of the thousands of error messages.


    Log Name: Application
    Source: Application Error
    Date: 9/24/2014 3:28:40 PM
    Event ID: 1000
    Task Category: (100)
    Level: Error
    Keywords: Classic
    User: N/A
    Computer: DavidsDesktop
    Description:
    Faulting application name: mpcmdrun.exe, version: 4.5.218.0, time stamp: 0x532c98e2
    Faulting module name: KERNELBASE.dll, version: 6.3.9600.17278, time stamp: 0x53eebd22
    Exception code: 0xc0000142
    Fault offset: 0x00000000000ec0b4
    Faulting process id: 0x28ccc
    Faulting application start time: 0x01cfd82dbf17e1e4
    Faulting application path: C:\Program Files\Windows Defender\mpcmdrun.exe
    Faulting module path: KERNELBASE.dll
    Report Id: fcc93278-4420-11e4-bfa1-4c72b9df5fb1
    Faulting package full name:
    Faulting package-relative application ID:
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-09-24T19:28:40.000000000Z" />
    <EventRecordID>4904581</EventRecordID>
    <Channel>Application</Channel>
    <Computer>DavidsDesktop</Computer>
    <Security />
    </System>
    <EventData>
    <Data>mpcmdrun.exe</Data>
    <Data>4.5.218.0</Data>
    <Data>532c98e2</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.3.9600.17278</Data>
    <Data>53eebd22</Data>
    <Data>c0000142</Data>
    <Data>00000000000ec0b4</Data>
    <Data>28ccc</Data>
    <Data>01cfd82dbf17e1e4</Data>
    <Data>C:\Program Files\Windows Defender\mpcmdrun.exe</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>fcc93278-4420-11e4-bfa1-4c72b9df5fb1</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    </EventData>
    </Event>

  4. #4
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default More Information

    I'm running the Home Edition of SBS&D. Also, when I try to turn Windows Defender, I get error messages indicating that Defender may be corrupted.

  5. #5
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,337

    Default

    Could you give me the error you get when you try to turn on Windows Defender,and it says it might be corrupted?Or,better yet,maybe you could take a screenshot of the error and attach the screenshot here.
    http://windows.microsoft.com/en-ca/w...reen=windows-8

    How is the computer,besides the error on system boot and the problems with Windows Defender?Any noticeable problems,etc.?

  6. #6
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default Windows Defender Problem

    The following is the error message upon attempting to start the Windows Defender Service:

    Windows could not start the Windows Defender Service on Local Computer.

    Error 577: Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.

    Overall, the computer seems to be running fine. Windows does lock up about once/week and that is relatively new.

  7. #7
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,337

    Default

    Ok,thanks.
    From what I'm seeing,Windows Defender will be disabled if it detects another antivirus program,and Error 577 is oftentimes seen when that happens.

    Which edition of Spybot 2.4.40 do you have,free,home or professional?
    Do you have any other antiviruses or security programs installed?
    If you do not have a program with real-time protection currently running,it might be best if you try to limit being on the internet as much as it is possible until this is fixed and/or figured out.(If you do have a program with real-time protection running currently,then you can disregard that,of course.)

    Also,when you have time,please have a look through Event Viewer once again,and see if you can find any errors with Spybot,as well.

  8. #8
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default Windows Defender

    I have the home version of SBS&D. I have no other virus or spyware protection running. I was using Norton, but once I purchased SBS&D, I uninstalled Norton using the Norton removal software that is supposed to remove any trace of Norton.

  9. #9
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,337

    Default

    Since Spybot Home edition includes Antivirus,that would be a likely reason that you would see Error 577,as Windows Defender would probably disable itself if it detected Spybot.
    In desktop mode,is the Spybot tray icon showing down by your computer clock?If it is,when you hover your mouse over it,does it show Live Protection:On?

    In Event Viewer,if you click on Error,then click View All Instances Of This Event,then under Actions,click Find,try typing in Spybot,and any instances of Spybot will be searched for,if it's mentioned.I tried it,and found an instance of Spybot in there,so it should work.If something is found,it should be highlighted,you can doubleclick it,select Copy,then Paste it here.This will give me some things to search for,I may not find a solution,but it will help maybe narrow what is wrong down,and hopefully get me closer.I've searched for Runtime Error 217,but that's a bit generic,and there are many,many instances of it when searching,and I cannot narrow down what might be happening.

  10. #10
    Junior Member
    Join Date
    Sep 2014
    Posts
    6

    Default Runtime error 217

    My operating system was showing signs of progressive failure. I therefore reloaded with a clean format of my OS partition. That will probably solve the problems I've been seeing, as no symptoms of previous problems are evident. Thank you for trying to help me avoid the OS reload.

    I have created a problem with my SBS&D license, however. When I was uninstalling/reinstalling (before the OS reload) I was asked whether to use the existing license or a new one and I selected new one. Now I receive a notification that SBS&D is installed on 3 computers when my license is only for two. When re installing SBS&D after my OS reload, I was not asked the new license/existing license question. I in fact have SBS&D installed only on two computers. How do I resolve?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •