I used Spybot Beacon to block out MS telemetry services and upon applying things I noticed Skype stops working after I apply Telemetry Hosts(extensive list), under Optional. I went through things that option will add to hosts and found out problem is in this line it applies to hosts: s.gateway.messenger.live.com

This will block Skype from connecting again. After you first apply it, if you had Skype running, it will still stay online. But after reboot or closing/opening Skype again it will fail to connect. Removing this line will fix it and Skype will connect. Do note that I did merge my Skype ID with my Hotmail account, so this could be source of my problem. But it might be nice to add warning to app for future users. Or perhaps moving that to separate option, so you can choose if you want Skype blocked. I personally still use it.

I just thought I should let you guys know or if anyone else has same problem, on how to fix it, without regular recommendation to simply remove everything from hosts file.