Results 1 to 6 of 6

Thread: surface rotation

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    21

    Default surface rotation

    No, not spherical objects.
    Before heading off to Microsoft and all that, any bright sparks here have any idea why my Surface has stopped rotating the screen when I turn it?
    Been thru all the settings and can't find a thing.
    Can switch from landscape to portrait in settings, but last week it rotated automatically, now it doesn't

    (Prob missing something obvs here...)

  2. #2
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,138

    Default

    You could go through the six solutions here, and see if anything works.
    https://support.microsoft.com/en-ca/...creen-rotation

  3. #3
    Junior Member
    Join Date
    Dec 2018
    Posts
    21

    Default

    hi again
    thanks for that, pointed me in the right direction.
    the link was for win 8, but looked for win 10 and this thread is interesting, it's obvs an issue. this one from a year ago.
    https://answers.microsoft.com/en-us/...c1ab74c?page=1
    There's no rotation lock at all on action centre for me.
    I'll live without it! At least I know I'm not the only one!
    (seems to have broken after last update, btw)

  4. #4
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,138

    Default

    Hello. You're welcome.
    The link I posted is the troubleshoot page for Surfaces with Windows 10. The 'Get help for Surface running Windows 8.1' link at the top of the page is a link to the troubleshoot page for Surfaces with Windows 8.1. If you click on it it has a 'Get help for Surface running Windows 10.' that links back to the original troubleshoot page. I noticed that when I first looked and found it a bit confusing, so clicked the links to ensure I posted the proper page.

    I noticed some of the people posting on that thread saying their auto rotate broke after an update as well. Not sure if it's related or not. Yes, at least you know others have the same issue. Maybe it will be fixed with an update or something. Good luck with it.

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    21

    Default solution that worked for me...

    yes, you're right. it says win 8 but is recently updated.
    went thru the hoops with this yesterday, including downloading new drivers. none of it worked.
    lots of ppl trying different things. issue seems to go back to 2012. basically the rotation lock vanishes from the action center.

    however, for anyone who may have same issue, what worked for me in the end was this -

    (If rotation lock icon is missing)
    Change to portrait mode in display settings.
    Restart.
    Screen comes back in landscape mode with rotation lock visible, and rotation is working again.

    remains to be seen how long it will last!
    not convinced now that it was an update. it's been going on too long for one recent update to be the cause. it's just plain glitchy, since win8

  6. #6
    Spybot Advisor Team Zenobia's Avatar
    Join Date
    Oct 2005
    Posts
    5,138

    Default

    I'm glad you got the automatic rotation working again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •